Create AIX 5.1 mksysb iso images for backup/restore
Provided you have enough disk space you could create 2 new volumes - 1 for the backup and the other for the iso images
For example to create a baklv logical volume for backup and a cdlv logical volume for iso images:
mklv -y baklv rootvg 300 (the 300 is enough to store all filesystems in my case)
mklv -y cdlv rootvg 12
mkfs -V jfs2 /dev/baklv
mkfs -V jfs2 /dev/cdlv
Make sure to exclude our new logical volumes from the mksysb image by creating a file /etc/exclude.rootvg with:
/backup
/mkcd
Get into single user mode
shutdown -m
Mount the new filesystems
mount -o log=/dev/hd8 /dev/cdlv /mkcd
mount -o log=/dev/hd8 /dev/baklv /backup
Create the mksysb iso images
mkcd -S -e -C /mkcd -I /backup/mkcd

No comments: